neither make nor make install commands work -- debian 12

Asked by violet clare

trying to install HPLIP on my laptop (a HP Pavilion from 2020, don't know if that's relevant). laptop runs Debian 12. i am a relatively new Linux user (as of ~Nov. 3 this year) which may be impacting my results.

other points of note:
- 64-bit OS
- if y'all need to know the model(?) of the printer i'm hoping to make this laptop work with, it's a HP Deskjet 4155e

i can get through step 4 in the manual install process before i start running into problems. when i run `make`, the terminal prints the following--

```make: *** No targets specified and no makefile found. Stop.```

am i doing something wrong?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

Debian has a modified HPLIP package in its own repositories.

sudo apt-get install hplip hplip-gui

Revision history for this message
violet clare (finalgirlfall) said :

i think it worked!!! :D thank you!!