whats going on lucid lynx

Asked by Omilan Truchon

For maybe the last three weeks after some updates "I think" my lucid lynx has all of a sudden developed a mind all of its own. I was using it rather than windows set ups I have. but now I'm sadly getting a tad fed up.
Firefox has updated recently and now I cannot get bookmarks up or history or the forward and back buttons are greyed out, yet I can open it fully in root in terminal. Skype and also pidgin I can only start in terminal as root user. I dont normally fiddle about much with programmes if they work but for no explicable reason these things have began happening. If I was in windows I'd automatically start hunting worms and trojans etc but here I don't know!

I wonder does anyone else have any similar problems or is it just lucky me again? countless reccies through google and other seminars reinstalling etc etc tried all those and still the same...


Question information

English Edit question
Ubuntu coreutils Edit question
No assignee Edit question
Solved by:
Eliah Kagan
Last query:
Last reply:
Revision history for this message
Best Eliah Kagan (degeneracypressure) said :

Do these problems occur for another user account? If you only have one user account, please create a second user account for testing purposes.

If it's just one user account that is affected, then you can probably fix the problem by changing the ownership and permissions of all files in the user's home directory to make them fully accessible to that user. To do that, log in as the affected user (i.e., as yourself, as you normally do), make sure you are not running any of the affected applications, and run the following command in the Terminal:

sudo chown -R `whoami`:`whoami` ~; chmod -R u+rw ~

To run that command, I recommend that you select and copy it to the clipboard, then paste it into the Terminal, rather than typing it out manually. A slight mistake will result in it not working, or not working properly, and could even potentially worsen the situation considerably. Please note that the characters at the beginning and end of each whoami are not single-quotes, but are instead free-standing accent marks (produced on a US/English keyboard by pressing the key immediately to the left of the numeral 1). For your convenience, you can copy that text from Firefox into the Terminal, then quit Firefox (and any other affected applications, wait ten seconds or so, to allow them to finish quitting, and then press enter in the Terminal to run the command).

If the problem affects multiple user accounts or that proposed solution is unsuccessful, please post a reply here, and if you ran the above command (but it wasn't successful), please post all the text from the Terminal (Edit > Select All; Edit > Copy, then paste it here), even if it doesn't seem that running the command produced any output.

Finally, please note that it is a bad idea to run all but a small minority of graphical applications with sudo. You should instead use gksu (or gksudo, if you prefer), or, in Kubuntu, kdesudo. See https://help.ubuntu.com/community/RootSudo for details. Running graphical applications with sudo tends to produce precisely the sort of problem that you are currently experiencing (but that is not to say that doing so was necessarily the cause in this case).

Revision history for this message
Omilan Truchon (omilant) said :

Hi Eliah, thanks for your response, well I set up an alternative user account and once I got over the initial shock of how bare the desk top was compared to what I am used to I actually had to feel my way around again before being able to access programmes. Ive been using ubuntu about 13 months and have been pretty impressed. The challenges and use of brain to solve some problems are great. As for this current problem ( sorry about the rambling )The software just popped straight up and is useable as an alternative user with out any problem and at lightenning speed compared to what I have been used to.

I had to use root before as it was the only way I could get the programmes mentioned running and that only after I read it as a shot to get a programme going.

The funny thing is just before attempting to verify the problem firefox popped up as normal as you like with everything working, which in it self is another strange occurence.... So I think you have hit the nail on the head in one go maybe Im a bit naieve and didnt think to set up an alternateative account to verify the problem having ploughed through acres of "experts" comments in various blogs.

I'll fiddle a bit longer and then start in earnest to change the account and privaliges and I thank you for your assitance. Thank you

Revision history for this message
Omilan Truchon (omilant) said :

Thanks Eliah Kagan, that solved my question.