upgrade to ubuntu 11.10 messed up my users

Asked by derrick ayerz

Recently upgraded to Ubuntu 11.10 Problem at first was with ICEauthority.

I found an online solution buy hitting control f3 then logging in there and typing:

sudo chown usernamex:usernamex ~/.ICEauthority

this allowed me to log in but now the home page just has all my old folders and they are all right protected. I can open some of the documents but not others. I get screens saying I am either not the owner or that I don't have permissions.

Also there are no apps on the homepage and I cant add them - no menubar with firefox, etc. I can log into the guest account and the menubar and apps all work there (i am logged in as guest now).

If I go into users - it shows my account 'usernamex' and shows that I am an administrator - but when I log in under that account is looks like I don't have administrator privileges

Question information

English Edit question
Ubuntu coreutils Edit question
No assignee Edit question
Solved by:
derrick ayerz
Last query:
Last reply:
Revision history for this message
Chris (fabricator4) said :

You only have administrator privileges when you use 'sudo'. The problem with your home folder is the same as the one with the .ICEauthority - it's not listed as belonging to you for some reason. The solution is almost the same, but must be done on all files and folders in your /home recursively:

sudo chown -R usernamex:usernamex ~/*


Revision history for this message
Ralph Corderoy (ralph-inputplus) said :

If that chown is the solution I would expect it needs to apply to everything starting at the home directory, not everything matched by the glob `*' in the home directory, that ignores things that start with a `.', e.g.

    sudo chown -R $USER:$USER ~

Revision history for this message
derrick ayerz (derrick-ayers106) said :

Thanks guys - that unlocked all the folders.

One more problem - my home page doesn't contain a launchbar. I can open any of the docs and folders there - but I can figure out how to add the launchbar and programs.

Any advice would be most appreciated.


Revision history for this message
Chris (fabricator4) said :

The Launchbar is on the desktop. If you mean the sidebar in Nautilus (File manager) then to get it to show go
      --->Show Sidebar

or just press <F9>

If the Launcher really is missing, look here:

If you have any further problems you should start a new question, preferably for each problem.


Revision history for this message
derrick ayerz (derrick-ayers106) said :

This seemed to have fixed the main problem. I'm going to mark this one as solved and post a new one about the Launcher.

Thanks for your help