Deja Dup stops during backup of VirtualBox virtual hard drive

Asked by Christopher

Deja Dup is a nice, easy to use backup application, but it chokes when trying to backup a VirtualBox virtual hard drive. I left my desktop running the backup for 36+ hours, but it didn't progress further than 30%, sticking on the virtual drive(s).

Is there a workaround? I would really like to backup the virtual drives as well as all other files in my Home directory. Grsync doesn't fare any better.

I'm not really a terminal person, but can follow detailed instructions.

Question information

English Edit question
Ubuntu deja-dup Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
François Tissandier (baloo) said :


A few questions first:

-How big is your VM ?
-Was it running when you tried to run the backup ?
-Where are u trying to save your files ? (local hard drive, remote computer, etc...)

thanks !

Revision history for this message
Christopher (soft-kristal) said :

I have two - one is 10GB and the other is 20GB. I'm trying to back them up onto a FAT32 USB hard drive. Neither was running at the time, nor was anything other application, other than Deja Dup.

Revision history for this message
François Tissandier (baloo) said :

Check by yourself for confirmation, but according to Wikipedia, FAT32 partitions have a limitation of 4GB per file:

"The maximum possible size for a file on a FAT32 volume is 4 GiB minus 1 byte (232−1 bytes)"

I guess you know why it's not working now :)

-cup the files in smaller parts. That's possible from Virtualbox, but only when you create the VM I think. You can set the max file size (eg: 2GB), then Virtualbox will create multiple files.
-don't bother with this limitation from a filesystem of the previous century. You can use NTFS, it's supported both by Windows and Ubuntu. I don't know for MacOSX though...
-you can use any of the FS supported by Ubuntu (like ext4), but then, it's not so easy to share it with a Windows system. Ext2 can be shared using a driver. Ext4 CANNOT be shared unless if you deactivate an option. So that sounds a bit complicated...

I don't know if someone else has a better idea of a FS to use for the backups. I would probably go for NTFS if you really need to access this USB harddrive from Windows. That sounds like the easiest solution, but you should maybe check before if the rights management is not a problem (will another computer be able to access your files on the harddrive as it's not the owner of the files? I'm not sure about this one...).

Revision history for this message
Christopher (soft-kristal) said :

I think I'll try partitioning the USB drive and format it as NTFS. I only need it (Windows) once in the proverbial blue moon anyway.

Revision history for this message
Christopher (soft-kristal) said :

I'm back to square one - after creating an NTFS partition on an external USB drive, I tried again and it stuck at around the same point as before.

Revision history for this message
François Tissandier (baloo) said :

That was too easy...
Did you try to run Deja Dup from the command line to see if there was any interesting info appearing in the terminal? Usually it's the case.

To run it from the terminal, just open it, then type "deja-dup" I think. It will run the software as if u clicked in the menu, but usually there is complementary info in the terminal. Just run a backup for your VMs and see what appears.

Also, monitor your harddrive / processor usage while it's running. When it's stucked, is the computer quiet? (processor almost idle, disk idle too) ?

If there is nothing interesting with this test, I'm curious to see what a manual rsync copy (without any compression / encryption / incremental backup) would do.

Revision history for this message
Christopher (soft-kristal) said :

FYI - Grsync successfully copied two VirtualBox virtual drives to the NTFS partition. I didn't try some of the other settings: compression, encryption etc, as I don't have anything sensitive on the drives.