Deja Dup passwords

Asked by Dave Allen

I have a backup made with Deja Dup. I wish to reatore a file I have lost. Deja Dup requires a backup password, which I got wrong, so it aborted. But now if I retry, I am not asked for a password, and Deja Dup aborts with the message incorrect password'. I have restarted the system; I have deleted and reinstalled Deja Dup; but I still get the message! How do I rectify this situation?

Question information

English Edit question
Ubuntu deja-dup Edit question
No assignee Edit question
Solved by:
Hilario J. Montoliu (hjmf)
Last query:
Last reply:
Revision history for this message
Best Hilario J. Montoliu (hjmf) (hmontoliu) said :


I have no idea about deja dup, so take my advice as a guess. Most linux progams store their settings in hidden directories in your user's home dir.

Search for a folder named /home/youruser/.dejadup orsomething similar and check the files it may have, or just delete that folder (that may force new settings and hence it may re-prompt for a password).

As I said before. It's just a guess


Revision history for this message
Dave Allen (davidallen131) said :

Thanks Hilario J. Montoliu (hjmf), that solved my question.

Revision history for this message
Michael Terry (mterry) said :

Dave, open the GNOME password manager Seahorse by going to "Applications->Accessories->Passwords and Encryption Keys". You should be able to find the deja-dup encryption key there and delete it.

Revision history for this message
Dave Allen (davidallen131) said :

Thanks Michael, but going there start two levels of 'loading' which seem to be loading the history of the world, or something that long. I've resolved the problem with Deja Dup by reloading it, and being a bit more careful as to what I select. It hasn't wanted a password again.