software-properties Build failure

Asked by Igor Pereira Formighieri

I'm having problems building the .deb packages from the original source code of "software-properties", because after being sent to the launchpad it gives a construction error even if I send the original code without any modification it still keeps giving me the error inform how can I successfully finish building the package?
Link buildlog:

Question information

English Edit question
Ubuntu software-properties Edit question
No assignee Edit question
Solved by:
Igor Pereira Formighieri
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

Compare your log with the buildlog of the package in the Ubuntu repository,

test_ppa_info_from_lp (tests.test_lp.LaunchpadPPATestCase) ... skipped 'skipping online tests unless TEST_ONLINE environment variable is set'


test_ppa_info_from_lp (tests.test_lp.LaunchpadPPATestCase) ... E: Caught signal ‘Terminated’: terminating immediately

It seems that you have to disable certain tests (I have no idea how to do that).

Revision history for this message
Manfred Hampl (m-hampl) said :
Revision history for this message
Colin Watson (cjwatson) said :

That certainly isn't the original software without any modifications (the packaging is part of the software for this purpose). I downloaded both software-properties and software-properties, ran debdiff (from the devscripts package) on both .dsc files; this showed a large number of differences, including things like a build-dependency on dh-virtualenv which seems rather unlikely to be appropriate, and all the checkinstall stuff. You should go through the diff and clean it up, I think - it's always best to exclude your local changes before asking for support.

That said, I did some debugging. Here's what I found:

 * Due to output buffering somewhere, the test output that you see in the build log is extremely misleading about where the hang is. Although it looks like the hang is in tests.test_lp.LaunchpadPPATestCase.test_ppa_info_from_lp, that test has actually finished (or in fact been skipped), and it's the next test along that hangs. (I discovered this by inserting a call to strace.)
 * Your change in to remove dbus-run-session is definitely wrong. Without dbus-run-session, the tests hang trying to talk to D-Bus.
 * Your version built cleanly when I copied that source package version into a separate PPA configured to install build-dependencies from your PPA.

So I think this may just be some unreliability in software-properties' test suite. If you're interested in chasing it down then you should be able to do that in a local sbuild(1) instance; but failing that, retrying the failed build of would probably have worked, and you should revert the change you made in I can't see any problem with Launchpad as such here; this all seems to be at most some problems with the package itself.

Revision history for this message
Colin Watson (cjwatson) said :

Note that Manfred's comment above is definitely *incorrect*, although I went down the same line of thought at first, having been misled by the confusing test output buffering.

Revision history for this message
Manfred Hampl (m-hampl) said :

Sorry if I created confusion with my attempt to help.
I will refrain from commenting questions where my level of expertise isn't sufficient.

Revision history for this message
Igor Pereira Formighieri (igorpf) said :

My problem has been solved, the packages have wrong modifications that I didn't accidentally notice!